GearHack

: :

Add Comment | Related Links | TrackBack
Related Content

Getting Sound Through rdesktop

If you have a Linux computer and sound is working on it, then you will be able to get sound through rdesktop. But it's not necessary easy, unless you are aware that there is a bug that prevents it. Good news is that there is a really simple work-around to make sound work.

To get sound to work through rdesktop, first make sure Windows is configured to pass sound through Remote Desktop. Open up "Control Panel" -> "Sounds and Audio Devices". You should see "Microsoft RDP Audio Driver". Next, if the "Device volume" is set to "Low", it is either because: 1) sound pass-through is not enabled; or 2) you reduced the volume to "Low". Try fixing #2 by moving the slider to "High", then click the "Apply" button. If the slider stays at "High", then it's #2 and you should now have sound. If the slider jumps back to "Low" then it's #1 (continue to next paragraph).

If the sound pass-through is diabled, then the volume slider will not stick. You'll have to enable it in rdesktop with the "-r sound" flag. But that feature is bugged. Luckily the work around is to use the "-r sound" flag twice. (My version of rdesktop is 1.3.1.) For example:

  rdesktop -r sound -r sound host.domain.com

Easy, eh? Once you have the sound pass-through enabled, you can test with the slider to see that it sticks after clicking the "Apply" button. Now you have sound forwarded to your Linux box.

Chieh Cheng
Mon, 19 Apr 2010 23:02:45 +0000

Note that the Windows volume control on the task bar will still show maximum sound volume even if sound is disabled through rdesktop.

Chieh Cheng
Mon, 26 Apr 2010 17:18:41 +0000

That did it for me THANKS a million!!!

ff
Tue, 22 Feb 2011 15:21:06 +0000

It's not a bug.
It will work correct if you use it like this:

rdesktop -r sound:local:alsa host.domain.com

yong
Fri, 17 Jun 2011 07:31:25 +0000

It's been a few years. None of the above suggestions work for me with rdesktop 1.6.0 on CentOS 6.3 with Windows 7 Professional. But

rdesktop -r sound -r disk HOSTNAME

does (surprisingly) work.

Larry
Fri, 17 Apr 2015 02:22:10 +0400

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

TrackBack

Send Ping | TrackBack URL | Spam Control

Title: rdesktop Pass-Through Sound Volume Defaults to Max
Weblog: GearHack
Excerpt: After getting sound to work through rdesktop, I disconnected and reconnected. Then I played a sound file and scare the $#@! out of me. It turned out that the volume had turned up to maximum. I played with the volume control a bit and then disconnected, reconnected, and found the volume to be set to . . .
Tracked: Mon, 19 Apr 2010 23:13:23 +0000

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 3 - 7?
Click button only once, please!

Messages, files, and images copyright by respective owners.


Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

49 Users Online


Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2017. All Rights Reserved.