GearHack

: :

Add Comment | Related Links | TrackBack
Related Content

Memory Card Reader Stopped Working on New MSi Wind U100

Well, I have moved the 160 GB hard drive (with Mac OS X installed) from the MSi Wind U100-279US to the MSi Wind U100-016US. But the card reader is not working. I can't remember if it worked before on the U100-279US. Searching a bit, I found this thread that claims the following:

I had this problem. Go to terminal and type uname -a and hit enter. Your kernel should be 9.4 if you are on 10.5.4. If it says 9.1, thats the problem and as said, install the 10.5.4 update. You can also install the 10.5.5 update but be prepared to re-install the kext for the video otherwise you might get dropped to 800x600 resolution.

So I checked my system. Sure enough, my Darwin Kernel version is 9.1.0. But I also looked in the "About This Mac" dialog, which claimed my installation is version 10.5.4. So I've already upgrade, but the Darwin kernel didn't get updated. That's interesting . . .

Chieh Cheng
Thu, 13 Nov 2008 21:06:30 +0000

This "MsiWindosx86: USB Problem...." thread helped me find the Mac OS X 10.5.4 Update. It help me bring Darwin Kernel up to 9.4.0. But the memory card reader still doesn't work. hmmmm . . .

Chieh Cheng
Thu, 13 Nov 2008 21:50:03 +0000

Wow. I can't believe it. The memory card reader does work, but only with my 4GB microSDHC and not my 2GB microSD nor my 128 MB microSD. That's just weird. Is that a SDHC-only card reader?

Chieh Cheng
Fri, 14 Nov 2008 00:56:49 +0000

Hmmm . . . now I plugged in the 4GB microSDHC and it doesn't work. Hardware issue?

Chieh Cheng
Fri, 14 Nov 2008 01:01:04 +0000

Ok, so after jamming a Memory Stick Duo into the slot (without the Memory Stick adapter), and having a mighty difficult time getting the tiny card out of the slot, the memory card reader now works with all the cards that didn't work before. So I guess it was a hardware problem that magically gotten fixed. I got lucky. :-)

Chieh Cheng
Fri, 14 Nov 2008 01:15:34 +0000

I'm not so sure it's a hardware problem anymore. I am now suspecting that maybe Mac OS X did not boot up with the correct driver some times. Because Mac OS X will not see the card sometimes. Yet, without doing anything other than rebooting the computer a few times, it would recognize the card. The Wind, on the other hand, tries to boot off the inserted memory card every time it is turned on with a memory card inserted. Very strange issue so far.

Chieh Cheng
Tue, 17 Mar 2009 19:19:28 +0000

I am pretty sure at this point that it was a driver load problem. Today, I turned it on from sleep again, plugged in my SD Card, but it doesn't recognize it. And I had tried to reinsert it a few times. Funny thing was that the computer did recognize the card a night before. Following a hunch, I put the computer to sleep again and turned it back on. Then I inserted the memory card and the computer recognized it immediately. Now I know for sure it's a Mac OS X driver issue.

Chieh Cheng
Mon, 06 Apr 2009 21:49:33 +0000

This for this comments. It helped me to solve my card reader problem. (It suddenly did not recognize SD/SDHC cards after I unplugged it w/o using the "safely remove hardware" - OS: XP).

jjcai
Sun, 21 Nov 2010 15:04:35 +0000

The Mac driver actually differs between the SD Card and SDHC Card. There are time where I can boot up the computer and it would recognize both SD Cards and SDHC Cards. Then there are other times where it would only recognize SD Cards but not SDHC Cards.

Chieh Cheng
Wed, 24 Nov 2010 01:15:35 +0000

This post can help you and others with the same problems .)
http://www.portlanditguy.com/msi-wind-netbook-internal-sd-ca . . .

[quote]
Shut down the Wind.
Disconnected / Remove everything inserted into the Wind (USB, SD, etc)
Disconnect the power cable and the battery.
Hold down the power button for about 5 seconds.
Reconnect battery and power cable and startup the Wind.
Reconnect anything you disconnected in the 2nd step.
Voila, SD card should now work, because you have successfully reset the PMU and start up Preferences.
[/quote]

Igor Moroz
Thu, 13 Oct 2011 18:07:21 +0000

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 9 - 0?
Click button only once, please!

TrackBack

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.


Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

34 Users Online


Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2017. All Rights Reserved.