GearHack

: :

Add Comment | Related Links | TrackBack
Related Content

VirtualBox Hackintosh Won't Boot

So I had a Hackintosh installed on my laptop for a while (search for "VirtualBox Hacintosh" on this site). It all worked fine until recently... Maybe after upgrading Virtualbox to version 5+. It's a real pity, because I do enjoy using the Mac OS X in a virtual machine.

Anyway, it stopped booting with following output (see screen shot):

boot0: GPT
boot0: test
boot0: test
boot0: done
boot1: /boot

It just gets stuck or hangs there. Not sure exactly what causes this problem.

Attached Image:

Mac OS X Boot Failure.png

Jake
Tue, 06 Dec 2016 02:02:40 +0300

I played around with the settings in VirtualBox for a while. And I did manage to get it to boot some times. I had to check the "Enable EFI (special OSes only)" checkbox (see screen shot below).

Originally this checkbox should not be enabled (see my other threads on installing the Hackintosh). But now it does. And the virtual machine only boots up fully every other time.

Attached Image:

Enable EFI.png

Jake
Tue, 06 Dec 2016 02:05:03 +0300

Even though I did get the Hackintosh to work with VirtualBox 5 by enabling the EFI, it has difficult booting, failing every other time. And when it did succeed in booting, it crashes on shutdown. Also, it only boots to 1024x768. The full resolution no longer works.

I just installed VirtualBox 5.1.12, which was released two days ago. But the problem persists. Looking to downgrade VirtualBox to get my Hackintosh to work again.

Jake
Fri, 23 Dec 2016 08:16:57 +0300

OK. I just downgraded VirtualBox to version 5.0.30 and the Hackintosh works again. So it's not version 5 that is the issue, it's version 5.1 that causes it to fail. Not sure why at this point. But at least I can continue to use the Hackintosh with VirtualBox 5.0.30.

Jake
Fri, 23 Dec 2016 08:27:38 +0300

VirtualBox 5.0.40 works with the Mac virtual machine. See 'VirtualBox Won't Launch After "Feature update to Windows 10, version 1703"' TrackBack below.

Jake
Wed, 10 May 2017 21:19:19 -0700

Thanks for this, saved me. I was having the same problem, the only thing that worked for me was version 5.0.40 - nothing older, nothing newer.

Bob
Wed, 05 Jul 2017 21:32:03 -0700

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

TrackBack

Send Ping | TrackBack URL | Spam Control

Title: VirtualBox Won't Launch After "Feature update to Windows 10, version 1703"
Weblog: GearHack
Excerpt: I removed VirtualBox 5.0.30 and installed latest version 5.1.22 and it starts. It works with my Ubuntu virtual machine, but now I'm back to the "VirtualBox Hackintosh Won't Boot" problem.
Tracked: Wed, 10 May 2017 20:54:01 -0700

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 9 - 5?
Click button only once, please!

Messages, files, and images copyright by respective owners.


Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

30 Users Online


Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2017. All Rights Reserved.