Add Comment | Related Links | TrackBack
Related Content

The device 'Generic volume' cannot be stopped right now

I have a lot of USB hard drive, flash memory cards, and other removable storage sitting around my computer. I connect and disconnect them all the time, depending on what data I need. Over time, I've learned to click on the "Safely remove USB Mass Storage Device - Drive(F:)" in Windows XP before actually unplugging a removable drive. However, sometimes I get the "Problem Ejecting USB Mass Storage Device" error dialog (see screen shot below). The dialog always says, "The device 'Generic volume' cannot be stopped right now. Try stopping the device again later."

This error dialog always gives me a headache at first, because I am forced to shutdown my computer and start over. But soon I learned the conditions that are giving me the error, so that I can change the condition to remove the drive without restarting Windows. The following are some of the conditions I know about:

  1. Hard drive is sleeping; being spun up. With some removable drives, the hard drive might spin down due to inactivity. When you try to "safely remove the drive", the drive is forced to spin up. During spin up, the drive is not ready and Windows XP is too impatient to wait. Try to "safely remove the drive" again after spinning up resolves this issue.
  2. Windows Explorer is showing the directory content on the drive. When any directory content is being displayed, Windows Explorer locks the drive so that it can't be un-mounted. Change Windows Explorer to a directory that is not on that drive usually solves this problem.
  3. Command Prompt is in a directory on the drive. Believe it or not, some of us are still using the Command Prompt. If your Command Prompt is currently in a directory on the drive, the drive is again locked. Change directory to another drive or exit Command Prompt to resolve this conflict.

I've listed several reasons why you can't unmount a drive in Windows XP. If you know of any other conditions, please feel free to share with us.

Attached Image:

Error Dialog.png

Chieh Cheng
Thu, 10 May 2007 19:05:55 -0700

I should mention that if all else fails and you can't safely remove the device no matter what you try, then it's time to shutdown the computer. 99% of the time, that will safely un-mount your device from your computer. When your computer is off, you can unplug your device.

Chieh Cheng
Wed, 30 Dec 2009 18:26:44 +0000

So you are saying that if i shut the computer with my external hard drive still attached, it will not damage my hard drive? Well that works with me.

Thu, 21 Jan 2010 19:08:51 +0000

Yes. As long as you select shutdown from the Start menu and let Windows shut down your computer to the point where your computer turns off, you will be fine.

Chieh Cheng
Thu, 21 Jan 2010 20:23:32 +0000

Pen drives have similar problems i.e hardware or virus problems. Some common problems and their uncommon solutions about pen drives are listed. . . .

Tue, 02 Mar 2010 01:33:18 +0000

When the computer hibernate or shut down with removable USB pluged, on return to Windows, this issue occurs.
Remove all removable USB before power-on, and plug in Windows, Autoplay run.Check the Safety Remove Hardware , it's works fine.

Mon, 22 Mar 2010 07:29:17 +0000

Sometimes you can shut down explorer but it's still working in the background (the ever ending prob with windows). there's some free software which can stop windows refusing to delete unwanted files, which also works with shutting down the process of explorer locking usb removal.

Fri, 01 Oct 2010 03:41:46 +0000

I will never get the recognition for this but the problem is with .mod files on the device. Explorer dont drop it handles to these files after thay have been accesed in any way ... such as enetring a directory with a .mod file on it ... I discovered this becuase I had to identical drives, one removed fine and the other didnt ... I had a rootfs.mod file on the problem drive ... So then I tested putting and empty txt file on a disk, renaming it test.mod ... bam locked volume ... ProcessNT show multiple handles to the files .... obviously killing explorer or the handles will allow the flash drive to be removed and it can be restarted but but ... I just sent this info as feedback on ... So if you removed the mod files, rename them or move them to a folder that will not be accessed or viewed by explorer, your drived will unmount ok ... I hope MS fix whatever the problem is in some update to explorer ...

Fri, 29 Oct 2010 06:36:53 +0000

I might have another connection related to the "...cannot be dismounted because it etc.." error. I haven't got it to work yet, but it might be another thing to try, at least another factor in the equation. One of my HDs has a directory called "Recycler", which seems to be temp storage for things I have deleted from the drive while it is mounted. I think it actually points to the recycle bin on my "C" drive. The same items show in the Recycle Bin. I emptied the R Bin, but this didn't clear it yet. Maybe it would for some people. BTW, I have tried your other sugg's but no luck yet.

John Chaffey
Mon, 14 Mar 2011 15:18:11 +0000

I found that if you're viewing an Adobe document from your USB drive, it never really "closes" even if you've exited out of it.

If you go to Task Manager (usually I just right-click on the Start bar in a blank space and choose it from the pop-up menu), then go to the Processes tab and look for "acrotray.exe" or something Adobe-y related.

Click on the Image Name column heading to sort it alphabetically if you can't see it right away. Then, I just highlight the file and click the "End Process" button. You'll get the typical warning message asking if you're sure you want to terminate it, just press Yes.

Windows XP should let go of your USB drive immediately through the typical steps to safely remove it.

I hope this helps someone!

Thu, 26 May 2011 23:44:23 +0000

I've found two reasons:
1) Windows system restore opens file handles on the drive. and
2) Antivirus products open file handles on the drive (I only use AVG and McAfee; AVG does this more frequently on my systems, ymmv)

{p.s. there are no numbers in my email address}

Morgan Glines
Thu, 01 Sep 2011 03:20:42 +0000


For me even closing or ending explorer.exe via taskmgr doesn't allow me to eject my usb drive.

I have tried using process explorer to close the file handle on that drive which seems to work.

I found it here: . . .

Primum Nocti
Mon, 14 Nov 2011 03:28:38 +0000

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.


TrackBack only accepted from WebSite-X Suite web sites. Do not submit TrackBacks from other sites.

Send Ping | TrackBack URL | Spam Control

Title: Unable to Safely Remove the Memory Card
Weblog: Camera Hacker
Excerpt: i was trying to transfer some files from my camera to my laptop, the time i was done, i tried to safely removed the device.. but it keeps on saying that it is used by another went on for almost an hour..and i have no other choice but to take the chord off ( i was using a usb chord, my di . . .
Tracked: Wed, 30 Dec 2009 18:25:22 +0000

Add Comment

Spam Control | * indicates required field
Your Name: *
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 5 + 2?
Click button only once, please!

Messages, files, and images copyright by respective owners.

Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

223 Users Online

Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2024. All Rights Reserved.