GearHack

: :

Add Comment | Related Links | TrackBack
Related Content

idrive torquemaster fuse

After the snow storm that recently hit our area one of our idrive doors became frozen stuck. When I tried to open it it hummed for a few seconds then quit. No beeps when hitting the reset button. After checking the owner's manual I figured the fuse is blown. The circuit board has a rectangular soldered in fuse that is identified on the board as 3.15A 250VAC. After checking ProDoorParts.com I see that there is a new replacement fuse that is listed as 15A. Is this the correct replacement upgrade? Thanks in advance.

T. Wilson
Thu, 05 Mar 2009 01:10:55 +0000

So it doesn't look like the fuse and the fuse holder that is in this the "Wayne Dalton idrive Troubleshooting Tip #1 - Check the Fuse" thread?

Chieh Cheng
Thu, 05 Mar 2009 01:16:52 +0000

No, I can't find a fuse holder anywhere on the board.

T. Wilson
Thu, 05 Mar 2009 02:05:26 +0000

I say if your circuit board shows "3.15A 250VAC", then that's what it is. Call Wayne Dalton to confirm. Or bring the circuit board or fuse to Radio Shack and find a direct replacement. I think the 15A fuse is way off.

Chieh Cheng
Thu, 05 Mar 2009 02:12:50 +0000

Ok, so my model does not have the normal glass fuse. There is a circular fuse that I can get from Digikey. My problem now is that the rectangular black piece that is on the board that I thought was some type of fuse is broken off and does not have enough wire to resolder. It is listed as P/N 296221 Rev. C, EMS 101303 SN 045573. Any idea what this is? Digikey probably has it but a search for those numbers yields nothing. My next choice would be to buy a new board. Pro Door Parts.com says their boards will fit all iDrive openers, but they have two different ones listed! My model is 3660-372. Thanks for your help.

T. Wilson
Sun, 22 Mar 2009 18:35:03 +0000

The black piece is not the fuse, see http://www.gearhack.com/Forums/Home/Wayne%20Dalton/Wayne_Dal . . .

John
Thu, 12 Apr 2012 06:02:53 +0400

Also i was able to replace my fuses without actually taking the board out by using some careful work with needle nose pliers, but then the motor died anyways... I would avoid Wayne Dalton and go with a conventional spring and opener system if you ever upgrade

John
Thu, 12 Apr 2012 06:06:57 +0400

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

TrackBack

Send Ping | TrackBack URL | Spam Control

Title: I drive torquemaster no power,no beeps
Weblog: GearHack
Excerpt: I have a 12 year old I Drive Torquemaster that was working fine and just stopped opening and I get no beeps when i try to open, Ive tried using all remotes and have power to the opener and the light does not come on either i have put the remote right next to the opener and it will still not do anyth . . .
Tracked: Tue, 26 Mar 2013 09:16:39 +0300

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 8 - 8?
Click button only once, please!

Messages, files, and images copyright by respective owners.


Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

27 Users Online


Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2017. All Rights Reserved.