GearHack

: :

Add Comment | Related Links | TrackBack
Related Content

Google Play "Authentication is required."

I have just upgraded to Android 4.1 (Jelly Bean) on my Samsung Galaxy Nexus (the unlocked version sold by Google Play). Now I can't seem to access the Google Play store any more. Whenever I start Google Play, it displays the following message:

"Authentication is required. you need to sign into your Google Account."

I tried Gmail and it accesses my account just fine. I also pulled down the Google Play menu options and selected "Accounts". Then I selected the account I want to use. But the same problem presists. How do I sign into my Google Account on Google Play?

Jake
Tue, 24 Jul 2012 21:59:49 +0400

Go to manage apps, find google play store, disable clear cache and enable again. worked for me.

Qusai
Sat, 28 Jul 2012 01:04:00 +0400

I have the same problem , I did every solution which I found on the internet , I also disabled , cleared cache and enable it again , but the problem still exist .
Pleaseeeeeeeeeee what should I do with my samsung Tablet Galaxy Tab 2 ?!!!!! :-(

hojat
Wed, 14 Nov 2012 00:19:23 +0300

I remember Qusai's suggestion of clearing the cache did not work for me. I ended up doing the last resort, which was to do a factory data reset on the phone. It erased everything. Afterward, I was able to download from the Play store again.

By the way, if you decide to go this route, be sure to follow this tip: Preparation Before "Factory data reset" on Android

Jake
Wed, 14 Nov 2012 05:18:10 +0300

I have tried all of the above:
- clear cache
- disable / enable
- factory reset
Nothing works.
And it seems like there are a few people out there with the same issue. But there are no answers :(

Emily
Wed, 28 Nov 2012 15:29:39 +0300

I had the very same problem. Nothing worked. I rummaged around and guess what? Somehow the wifi was cut off (how I don't know, my gmail.com account still came up with emails, probably downloaded to my device Galaxy Tab).

So pull down the updates (bar at top on power up) and click on wifi on far left.

I then went to google play and it had authenticated.

David Cox
Mon, 18 Feb 2013 18:51:33 +0300

Went to Application Management -> Play Store -> Clear Data and that did the trick (when "Clear Cache" did not initially resolve it).

Jason
Fri, 10 Oct 2014 02:58:59 +0400

I had the same problem. here is how I solved it. From my phone, I went to the Chrome app. Opened "Settings" then opened the "Sign in" tab. As I had two accounts, I selected the one I needed to sign in as and then entered my password and "TaTa" I was in and then everything worked.

I hope this helps you.

Richard
Thu, 25 Dec 2014 22:22:55 +0300

Add Comment | Related Links | TrackBack
Related Content

Did your message disappear? Read the Forums FAQ.

Add Comment

Spam Control | * indicates required field
Your Name: *
E-mail:
Remember Me!
Comment: *
File attachment is optional. Please do not attach a file to your submission unless it is relevent.
Attach File:
(20 MB Max)
Spam Protection: * Answer of 2 - 5?
Click button only once, please!

TrackBack

Send Ping | TrackBack URL | Spam Control

No TrackBacks yet. TrackBack can be used to link this thread to your weblog, or link your weblog to this thread. In addition, TrackBack can be used as a form of remote commenting. Rather than posting the comment directly on this thread, you can posts it on your own weblog. Then have your weblog sends a TrackBack ping to the TrackBack URL, so that your post would show up here.

Messages, files, and images copyright by respective owners.


Articles | Wiki
Forums | Latest | RSS
Library | Links | News
Search | Store | Help

37 Users Online


Hacking Digital Cameras
Fun for Photographers

Amazon Associate

Copyright © 2004 - 2017. All Rights Reserved.